aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-07-21 16:08:29 -0500
committerCharles Kerr <charles.kerr@canonical.com>2014-07-21 16:08:29 -0500
commit2cb851b018c5e7a0278dab75f73bb031c7c42422 (patch)
tree96ac2ec4202a68d1ae15f0a34ce6276d44ef7785 /CMakeLists.txt
parent8c4b964ee9fd6578f3b922357c58b933bf14e6df (diff)
downloadayatana-indicator-power-2cb851b018c5e7a0278dab75f73bb031c7c42422.tar.gz
ayatana-indicator-power-2cb851b018c5e7a0278dab75f73bb031c7c42422.tar.bz2
ayatana-indicator-power-2cb851b018c5e7a0278dab75f73bb031c7c42422.zip
add tests to confirm that the DBus object's PowerLevel property changes at the right times (and only at the right times) when the battery is draining
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d5d6a82..569100d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,7 +63,8 @@ add_custom_target (cppcheck COMMAND cppcheck --enable=all -q --error-exitcode=2
##
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set(C_WARNING_ARGS "${C_WARNING_ARGS} -Weverything -Wno-c++98-compat")
+ set(C_WARNING_ARGS "${C_WARNING_ARGS} -Weverything")
+ set(C_WARNING_ARGS "${C_WARNING_ARGS} -Wno-c++98-compat -Wno-padded") # these are annoying
set(C_WARNING_ARGS "${C_WARNING_ARGS} -Wno-documentation") # gtk-doc != doxygen
else()
set(C_WARNING_ARGS "${C_WARNING_ARGS} -Wall -Wextra -Wpedantic -Wformat=2")