aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-06-24 15:42:53 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-06-24 15:42:53 +0100
commit05c42721a5838b7408412270e79c810caff9069d (patch)
treec3399f1687cf05d2a039157a083b168f8a160ca9 /Makefile.am
parente2d0b048d348a415ad97298489af6d706a773c54 (diff)
downloadayatana-indicator-power-05c42721a5838b7408412270e79c810caff9069d.tar.gz
ayatana-indicator-power-05c42721a5838b7408412270e79c810caff9069d.tar.bz2
ayatana-indicator-power-05c42721a5838b7408412270e79c810caff9069d.zip
Some build fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 044881e..3d9a8b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,11 +6,11 @@ SUBDIRS = po
# DBus service file
dbus_servicesdir = $(DBUSSERVICEDIR)
-dbus_services_DATA = indicator-power.service
+dbus_services_DATA = data/indicator-power.service
# Rule to make the service file with libexecdir expanded
%.service: %.service.in
- sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
############################################################
@@ -23,7 +23,7 @@ libexec_PROGRAMS = indicator-power-service
powerlibdir = $(INDICATORDIR)
powerlib_LTLIBRARIES = libpower.la
libpower_la_SOURCES = \
- indicator-power.c
+ src/indicator-power.c
libpower_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
@@ -39,10 +39,11 @@ libpower_la_LDFLAGS = \
################
indicator_power_service_SOURCES = \
- power-service.c
+ src/power-service.c
indicator_power_service_CFLAGS = \
$(POWERSERVICE_CFLAGS) \
-Wall -Werror \
+ -DLOCALEDIR=\"$(localedir)\" \
-DG_LOG_DOMAIN=\"Power-Me\"
indicator_power_service_LDADD = \
$(POWERSERVICE_LIBS)