aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-08-22 20:38:36 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-08-22 20:38:36 +0100
commit84735ec5056e864684245f90a0116ce09cc42b8f (patch)
tree92495137fcc0ff51b7ed79a79f7bddd95c03512e /Makefile.am
parent94b05b3ac5e37146e6e049df4daf011e0b5689ae (diff)
downloadayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.tar.gz
ayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.tar.bz2
ayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.zip
Use gsettings to store the status of "Show time in Menu Bar" option
Fixes https://bugs.launchpad.net/indicator-power/+bug/829853
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 932775f..70af9f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,13 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = po
+gsettingsschema_in_files = data/org.ubuntu.indicator-power.gschema.xml.in
+gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
+
+@INTLTOOL_XML_NOMERGE_RULE@
+
+@GSETTINGS_RULES@
+
###################
# Indicator Stuff
###################
@@ -24,7 +31,12 @@ libpower_la_LDFLAGS = \
############################################################
-EXTRA_DIST = autogen.sh
+EXTRA_DIST = \
+ $(gsettingsschema_in_files) \
+ autogen.sh
+
+CLEANFILES = \
+ $(gsettings_SCHEMAS)
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall