aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-06-24 15:25:17 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-06-24 15:25:17 +0100
commite2d0b048d348a415ad97298489af6d706a773c54 (patch)
tree2f6e5bb5af1103017529305144b5e4caf4fe4c77 /Makefile.am
downloadayatana-indicator-power-e2d0b048d348a415ad97298489af6d706a773c54.tar.gz
ayatana-indicator-power-e2d0b048d348a415ad97298489af6d706a773c54.tar.bz2
ayatana-indicator-power-e2d0b048d348a415ad97298489af6d706a773c54.zip
Initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..044881e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,82 @@
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+SUBDIRS = po
+
+############################################################
+
+# DBus service file
+dbus_servicesdir = $(DBUSSERVICEDIR)
+dbus_services_DATA = indicator-power.service
+
+# Rule to make the service file with libexecdir expanded
+%.service: %.service.in
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+############################################################
+
+libexec_PROGRAMS = indicator-power-service
+
+###################
+# Indicator Stuff
+###################
+
+powerlibdir = $(INDICATORDIR)
+powerlib_LTLIBRARIES = libpower.la
+libpower_la_SOURCES = \
+ indicator-power.c
+libpower_la_CFLAGS = \
+ $(INDICATOR_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Power\"
+libpower_la_LIBADD = \
+ $(INDICATOR_LIBS)
+libpower_la_LDFLAGS = \
+ -module \
+ -avoid-version
+
+################
+# Status Stuff
+################
+
+indicator_power_service_SOURCES = \
+ power-service.c
+indicator_power_service_CFLAGS = \
+ $(POWERSERVICE_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Power-Me\"
+indicator_power_service_LDADD = \
+ $(POWERSERVICE_LIBS)
+
+############################################################
+
+EXTRA_DIST = autogen.sh
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+############################################################
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi