aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-05-23 10:42:13 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-05-23 10:42:13 -0500
commit122e56d9e1b4b8d2f2b7bf3dd9daf5577d6b2699 (patch)
treed9aad591676bc976d98566ae28437490fdab9455 /Makefile.am
parent8e7ee28533094e6f3e5d9968e3841e5af38bf1ba (diff)
downloadayatana-indicator-power-122e56d9e1b4b8d2f2b7bf3dd9daf5577d6b2699.tar.gz
ayatana-indicator-power-122e56d9e1b4b8d2f2b7bf3dd9daf5577d6b2699.tar.bz2
ayatana-indicator-power-122e56d9e1b4b8d2f2b7bf3dd9daf5577d6b2699.zip
move libpower's automake rules into src/
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 1 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index 25cbee5..54ec6a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,30 +1,4 @@
-ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-
-SUBDIRS = \
- po \
- data
-
-###################
-# Indicator Stuff
-###################
-
-powerlibdir = $(INDICATORDIR)
-powerlib_LTLIBRARIES = libpower.la
-libpower_la_SOURCES = \
- src/indicator-power.c
-libpower_la_CFLAGS = \
- $(UPOWER_CFLAGS) \
- $(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall -Werror \
- -DG_LOG_DOMAIN=\"Indicator-Power\"
-libpower_la_LIBADD = \
- $(UPOWER_LIBS) \
- $(INDICATOR_LIBS)
-libpower_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module \
- -avoid-version
+SUBDIRS = po data src
############################################################