aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-02-14 23:42:19 +0100
committerSebastien Bacher <seb128@ubuntu.com>2012-02-14 23:42:19 +0100
commit4dcb232d4fd067f45a5a6b3a53dee535a209fa9e (patch)
tree4fb06888cc96d9d04aecbc4fccd4214de829d0bb /Makefile.am
parent1566633e5f966baf818d413c2166f4815780eedb (diff)
parentb33fcf3e703f9c6ed8e0be1aae92263e8697c551 (diff)
downloadayatana-indicator-power-4dcb232d4fd067f45a5a6b3a53dee535a209fa9e.tar.gz
ayatana-indicator-power-4dcb232d4fd067f45a5a6b3a53dee535a209fa9e.tar.bz2
ayatana-indicator-power-4dcb232d4fd067f45a5a6b3a53dee535a209fa9e.zip
releasing version 1.90-0ubuntu1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 41 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d4d34b..0ef4362 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,8 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = po
-
-gsettings_in_file = data/com.canonical.indicator.power.gschema.xml.in
-gsettings_SCHEMAS = $(gsettings_in_file:.xml.in=.xml)
-
-@INTLTOOL_XML_NOMERGE_RULE@
-
-@GSETTINGS_RULES@
+SUBDIRS = \
+ po \
+ data
###################
# Indicator Stuff
@@ -20,12 +15,14 @@ libpower_la_SOURCES = \
libpower_la_CFLAGS = \
$(UPOWER_CFLAGS) \
$(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DG_LOG_DOMAIN=\"Indicator-Power\"
libpower_la_LIBADD = \
$(UPOWER_LIBS) \
$(INDICATOR_LIBS)
libpower_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version
@@ -34,16 +31,6 @@ libpower_la_LDFLAGS = \
dist_noinst_SCRIPTS = \
autogen.sh
-dist_noinst_DATA = \
- data/com.canonical.indicator.power.gschema.xml \
- $(gsettings_in_file)
-
-CLEANFILES = \
- $(gsettings_SCHEMAS)
-
-MAINTAINERCLEANFILES = \
- $(gsettings_SCHEMAS:.xml=.valid)
-
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
############################################################
@@ -73,3 +60,39 @@ dist-hook:
else \
echo Failed to generate AUTHORS: not a branch >&2; \
fi
+
+
+# Coverage targets
+
+.PHONY: clean-gcda
+clean-gcda:
+ @echo Removing old coverage results
+ -find -name '*.gcda' -print | xargs -r rm
+
+.PHONY: coverage-html generate-coverage-html clean-coverage-html
+coverage-html: clean-gcda
+ -$(MAKE) $(AM_MAKEFLAGS) -k check
+ $(MAKE) $(AM_MAKEFLAGS) generate-coverage-html
+
+generate-coverage-html:
+ @echo Collecting coverage data
+ $(LCOV) --directory $(top_builddir) --capture --output-file coverage.info --no-checksum --compat-libtool
+ LANG=C $(GENHTML) --prefix $(top_builddir) --output-directory coveragereport --title "Code Coverage" --legend --show-details coverage.info
+
+clean-coverage-html: clean-gcda
+ -$(LCOV) --directory $(top_builddir) -z
+ -rm -rf coverage.info coveragereport
+
+.PHONY: coverage-xml generate-coverage-xml clean-coverage-xml
+coverage-xml: clean-gcda
+ -$(MAKE) $(AM_MAKEFLAGS) -k check
+ $(MAKE) $(AM_MAKEFLAGS) generate-coverage-xml
+
+generate-coverage-xml:
+ @echo Generating coverage XML report
+ $(GCOVR) -x -r $(top_builddir) -o $(top_builddir)/coverage.xml
+
+clean-coverage-xml: clean-gcda
+ -rm -rf $(top_builddir)/coverage.xml
+
+clean-local: clean-coverage-html clean-coverage-xml