aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-07-01 23:48:23 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-07-01 23:48:23 +0100
commit73d6282a5ebd4da9deeeb1adadbafd0ccb4dbbff (patch)
tree40306e85fbb0c634d8c7cef71d9029f35624c4dd /configure.ac
parenta3ebc78410655fb64f727cef607578eea4a45553 (diff)
downloadayatana-indicator-power-73d6282a5ebd4da9deeeb1adadbafd0ccb4dbbff.tar.gz
ayatana-indicator-power-73d6282a5ebd4da9deeeb1adadbafd0ccb4dbbff.tar.bz2
ayatana-indicator-power-73d6282a5ebd4da9deeeb1adadbafd0ccb4dbbff.zip
configure.ac: Remove the GTK+2 support
We have GTK+3 in oneiric and we use the gnome-power-manager 3 dbus interface anyway
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 4 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 3f7e4d5..9a78590 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,25 +37,10 @@ INDICATOR_REQUIRED_VERSION=0.3.0
UPOWER_REQUIRED_VERSION=0.9.5
PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
-
-AC_ARG_WITH([gtk],
- [AS_HELP_STRING([--with-gtk],
- [Which version of gtk to use for the indicator @<:@default=3@:>@])],
- [],
- [with_gtk=3])
-
-AS_IF([test "x$with_gtk" = x3],
- [PKG_CHECK_MODULES([INDICATOR],[
- gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- indicator3 >= $INDICATOR_REQUIRED_VERSION])],
- [test "x$with_gtk" = x2],
- [PKG_CHECK_MODULES([INDICATOR],[
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- indicator >= $INDICATOR_REQUIRED_VERSION])],
- [AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
-)
-AC_SUBST(INDICATOR_CFLAGS)
-AC_SUBST(INDICATOR_LIBS)
+PKG_CHECK_MODULES([INDICATOR],[
+ gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ indicator3 >= $INDICATOR_REQUIRED_VERSION
+])
###########################
# Check to see if we're local
@@ -143,5 +128,4 @@ AC_MSG_NOTICE([
Power Indicator Configuration:
Prefix: $prefix
- GTK: $with_gtk
])