aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-07-08 14:39:48 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-07-08 14:39:48 +0100
commit7652767580f7b8be6761ccf5b5dc7a303d51348c (patch)
tree0dc3d1f88e5fe9c2d092eab621b35eb6d8dbbe65 /configure.ac
parentaefbd30eb589d856e3211d7299a59e0d6ad772ff (diff)
downloadayatana-indicator-power-7652767580f7b8be6761ccf5b5dc7a303d51348c.tar.gz
ayatana-indicator-power-7652767580f7b8be6761ccf5b5dc7a303d51348c.tar.bz2
ayatana-indicator-power-7652767580f7b8be6761ccf5b5dc7a303d51348c.zip
configure.ac: Add support for the new indicator3-0.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 94b0644..8766b1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,13 +30,13 @@ LT_INIT
###########################
GTK_REQUIRED_VERSION=3.0
-INDICATOR_REQUIRED_VERSION=0.3.0
+INDICATOR_REQUIRED_VERSION=0.3.90
UPOWER_REQUIRED_VERSION=0.9.5
PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
PKG_CHECK_MODULES([INDICATOR],[
gtk+-3.0 >= $GTK_REQUIRED_VERSION
- indicator3 >= $INDICATOR_REQUIRED_VERSION
+ indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
])
###########################
@@ -54,16 +54,11 @@ AC_ARG_ENABLE([localinstall],
# Indicator Info
###########################
-if test "x$with_localinstall" = "xyes"; then
- INDICATORDIR="${libdir}/indicators/3/"
- INDICATORICONSDIR="${datadir}/indicator-applet/icons/"
-elif test "x$with_gtk" = x2; then
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
-else
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3`
-fi
+AS_IF([test "x$with_localinstall" = "xyes"],
+ [INDICATORDIR="${libdir}/indicators3/2/"
+ INDICATORICONSDIR="${datadir}/indicator-applet/icons/"],
+ [INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`])
AC_SUBST(INDICATORDIR)
AC_SUBST(INDICATORICONSDIR)