aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-08-22 20:38:36 +0100
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-08-22 20:38:36 +0100
commit84735ec5056e864684245f90a0116ce09cc42b8f (patch)
tree92495137fcc0ff51b7ed79a79f7bddd95c03512e /configure.ac
parent94b05b3ac5e37146e6e049df4daf011e0b5689ae (diff)
downloadayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.tar.gz
ayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.tar.bz2
ayatana-indicator-power-84735ec5056e864684245f90a0116ce09cc42b8f.zip
Use gsettings to store the status of "Show time in Menu Bar" option
Fixes https://bugs.launchpad.net/indicator-power/+bug/829853
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 19ca570..94a94bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ LT_INIT
###########################
# Dependencies
###########################
-
+GIO_REQUIRED_VERSION=2.26
GTK_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.90
UPOWER_REQUIRED_VERSION=0.9.5
@@ -36,12 +36,18 @@ GSD_REQUIRED_VERSION=3.1.4
PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
PKG_CHECK_MODULES([INDICATOR],[
+ gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-3.0 >= $GTK_REQUIRED_VERSION
indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
])
PKG_CHECK_MODULES([GSD],[gnome-settings-daemon >= $GSD_REQUIRED_VERSION])
###########################
+# GSETTINGS
+###########################
+GLIB_GSETTINGS
+
+###########################
# Check to see if we're local
###########################