aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <javier.jardon@codethink.co.uk>2011-07-18 15:40:17 +0200
committerJavier Jardón <javier.jardon@codethink.co.uk>2011-07-18 15:40:17 +0200
commit99c94ace2b89cbef26d72dac5edfd3f309ba2269 (patch)
tree42236254109b551ee5db241730389ad5450d24e9 /configure.ac
parent8b03674c7f622f790e65cea59343c31865451c43 (diff)
downloadayatana-indicator-power-99c94ace2b89cbef26d72dac5edfd3f309ba2269.tar.gz
ayatana-indicator-power-99c94ace2b89cbef26d72dac5edfd3f309ba2269.tar.bz2
ayatana-indicator-power-99c94ace2b89cbef26d72dac5edfd3f309ba2269.zip
Use the new D-Bus interface if gnome-settings-daemon is new enough
Prepare the indicator-power about the changes upstream, where the code from gnome-power-manager is being moved to gnome-settings-daemon
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 99780b6..54a9a4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,12 +32,16 @@ LT_INIT
GTK_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.90
UPOWER_REQUIRED_VERSION=0.9.5
+GSD_REQUIRED_VERSION=3.1.4
PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
PKG_CHECK_MODULES([INDICATOR],[
gtk+-3.0 >= $GTK_REQUIRED_VERSION
indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
])
+PKG_CHECK_MODULES([GSD],[gnome-settings-daemon>= $GSD_REQUIRED_VERSION],
+ [have_gsd=yes],[have_gsd=no])
+AM_CONDITIONAL([HAVE_GSD],[test x$have_gsd = xyes])
###########################
# Check to see if we're local