aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2011-12-06 19:04:27 -0600
committerAllan LeSage <allanlesage@gmail.com>2011-12-06 19:04:27 -0600
commitb93d786ba481f09aa56e4666b378c6ac66d6850d (patch)
tree85fa6e1461fd96ae6966ca73accefcbcdc28ada4 /configure.ac
parent31651dddeaa9dce1d51b0b78ccdcf98c118ca06e (diff)
downloadayatana-indicator-power-b93d786ba481f09aa56e4666b378c6ac66d6850d.tar.gz
ayatana-indicator-power-b93d786ba481f09aa56e4666b378c6ac66d6850d.tar.bz2
ayatana-indicator-power-b93d786ba481f09aa56e4666b378c6ac66d6850d.zip
Added coverage reporting via gcov config and targets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d42c3c..0177f3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,16 @@ PKG_CHECK_MODULES([GSD],[gnome-settings-daemon >= $GSD_REQUIRED_VERSION])
GLIB_GSETTINGS
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -118,4 +128,5 @@ Power Indicator Configuration:
Prefix: $prefix
Local Install: $with_localinstall
+ gcov: $use_gcov
])