aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-10 15:51:42 -0600
committerTed Gould <ted@gould.cx>2012-02-10 15:51:42 -0600
commitc8ccec624f8ea5927217557b07c0258ceb94a77c (patch)
tree8fee3668376814f23eac0981a45300ca1de26252 /configure.ac
parent5e7445585d40682f25f0a2a9f434489238bf6f2b (diff)
parentb93d786ba481f09aa56e4666b378c6ac66d6850d (diff)
downloadayatana-indicator-power-c8ccec624f8ea5927217557b07c0258ceb94a77c.tar.gz
ayatana-indicator-power-c8ccec624f8ea5927217557b07c0258ceb94a77c.tar.bz2
ayatana-indicator-power-c8ccec624f8ea5927217557b07c0258ceb94a77c.zip
Support building coverage targets
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d42c3c..0177f3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,16 @@ PKG_CHECK_MODULES([GSD],[gnome-settings-daemon >= $GSD_REQUIRED_VERSION])
GLIB_GSETTINGS
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -118,4 +128,5 @@ Power Indicator Configuration:
Prefix: $prefix
Local Install: $with_localinstall
+ gcov: $use_gcov
])