aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-14 16:25:10 -0600
committerTed Gould <ted@gould.cx>2012-02-14 16:25:10 -0600
commit55cbd83e46951e9ddb0c38e5403470d775297116 (patch)
tree7495e32475b52a36a0ce4ac299d7ae66b9a9d3dd /configure.ac
parent8541fa2fca5e702df025c670f7d03bceb66ca2aa (diff)
parent1651ec12b187309fbf8934d37540e38a515409dd (diff)
downloadayatana-indicator-power-55cbd83e46951e9ddb0c38e5403470d775297116.tar.gz
ayatana-indicator-power-55cbd83e46951e9ddb0c38e5403470d775297116.tar.bz2
ayatana-indicator-power-55cbd83e46951e9ddb0c38e5403470d775297116.zip
Import upstream version 1.90
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d42c3c..406a93c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_INIT([indicator-power],
- [0.10],
+ [1.90],
[http://bugs.launchpad.net/indicator-power],
[indicator-power],
[http://launchpad.net/indicator-power])
@@ -48,6 +48,16 @@ PKG_CHECK_MODULES([GSD],[gnome-settings-daemon >= $GSD_REQUIRED_VERSION])
GLIB_GSETTINGS
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -105,6 +115,7 @@ AC_DEFINE([GETTEXT_PACKAGE],[PACKAGE_TARNAME],[Define to the gettext package nam
AC_CONFIG_FILES([
Makefile
po/Makefile.in
+data/Makefile
])
AC_OUTPUT
@@ -118,4 +129,5 @@ Power Indicator Configuration:
Prefix: $prefix
Local Install: $with_localinstall
+ gcov: $use_gcov
])