aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-09-13 16:38:45 +0200
committerRobert Tari <robert@tari.in>2022-09-13 16:38:45 +0200
commitee9f029e6742f3b1fd6506164898e6ff416ae07e (patch)
treecf5bd58114fcecfebe781b319a80b51411357872 /data/CMakeLists.txt
parentbeaa19ff667a4e259356556d9653f608cd0b48d1 (diff)
parentb0aa9020581e9e7d961d946716de56c61ee26be2 (diff)
downloadayatana-indicator-power-ee9f029e6742f3b1fd6506164898e6ff416ae07e.tar.gz
ayatana-indicator-power-ee9f029e6742f3b1fd6506164898e6ff416ae07e.tar.bz2
ayatana-indicator-power-ee9f029e6742f3b1fd6506164898e6ff416ae07e.zip
Merge branch 'sunweaver-pr/fix-and-update-translation-template'
Attributes GH PR #64: https://github.com/AyatanaIndicators/ayatana-indicator-power/pull/64
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index e269b30..c445b3c 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -3,13 +3,6 @@
##
set (SCHEMA_NAME "org.ayatana.indicator.power.gschema.xml")
-set (SCHEMA_FILE "${CMAKE_CURRENT_BINARY_DIR}/${SCHEMA_NAME}")
-set (SCHEMA_FILE_IN "${CMAKE_CURRENT_SOURCE_DIR}/${SCHEMA_NAME}.in")
-
-# generate the .xml file using intltool
-find_package(Intltool REQUIRED)
-set (ENV{LC_ALL} "C")
-intltool_merge_translations("${SCHEMA_FILE_IN}" "${SCHEMA_FILE}" ALL UTF8 STYLE "xml" NO_TRANSLATIONS)
# let GSettings do the rest
find_package(GSettings REQUIRED)