aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-10-15 02:45:50 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-10-15 02:45:50 +0000
commit24966789fc551c90857a848cebae75917fa9cc2d (patch)
tree30fae10e06f643d665a9ff88e9f47f3da63faf45 /src/CMakeLists.txt
parent7251f3df13dc2503791fc7d1b485a48636a15884 (diff)
parentee53f5d18009dba3cf69ddb2e2135ae2197c43b2 (diff)
downloadayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.tar.gz
ayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.tar.bz2
ayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.zip
Add mock battery support to make QA testing easier. Fixes: 1373511
Approved by: Antti Kaijanmäki, PS Jenkins bot, Ted Gould
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f7efb80..6f4bfaf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -6,10 +6,12 @@ add_definitions(-DG_LOG_DOMAIN="Indicator-Power")
# handwritten sources
set(SERVICE_MANUAL_SOURCES
brightness.c
+ device-provider-mock.c
device-provider-upower.c
device-provider.c
device.c
notifier.c
+ testing.c
service.c)
# generated sources
@@ -19,6 +21,10 @@ add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-battery
com.canonical.indicator.power
Dbus
${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.power.Battery.xml)
+add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-testing
+ com.canonical.indicator.power
+ Dbus
+ ${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.power.Testing.xml)
# add the bin dir to our include path so the code can find the generated header files
include_directories(${CMAKE_CURRENT_BINARY_DIR})