aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-07-11 21:39:51 +0200
committerSebastien Bacher <seb128@ubuntu.com>2012-07-11 21:39:51 +0200
commit4af0bd2bf3acca2dc08656ba0e7105a28e2d0d1b (patch)
tree403adab544ae9d295497f0c9d5eee5eb2d37c3a3 /src/Makefile.am
parent109d4fe4271cef7438273eb5a24b719a73e9a4fb (diff)
parent7bc1a483d52707854f6f813fbbbed4709fe38f34 (diff)
downloadayatana-indicator-power-4af0bd2bf3acca2dc08656ba0e7105a28e2d0d1b.tar.gz
ayatana-indicator-power-4af0bd2bf3acca2dc08656ba0e7105a28e2d0d1b.tar.bz2
ayatana-indicator-power-4af0bd2bf3acca2dc08656ba0e7105a28e2d0d1b.zip
Import upstream version 12.10.0
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b2cf3df
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,36 @@
+CLEANFILES =
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+###################
+# Indicator Stuff
+###################
+
+powerlibdir = $(INDICATORDIR)
+powerlib_LTLIBRARIES = libpower.la
+
+libpower_la_SOURCES = \
+ dbus-listener.c \
+ dbus-listener.h \
+ device.c \
+ device.h \
+ indicator-power.h \
+ indicator-power.c
+
+CLEANFILES += .libs/*.gcda .libs/*.gcno *.gcda *.gcno
+
+libpower_la_CFLAGS = \
+ $(UPOWER_CFLAGS) \
+ $(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Power\"
+
+libpower_la_LIBADD = \
+ $(UPOWER_LIBS) \
+ $(INDICATOR_LIBS)
+
+libpower_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module \
+ -avoid-version
+