aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-05-24 09:49:30 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-05-24 09:49:30 -0500
commit622c18549745d3824713fd9d7a4a0d89b31257a5 (patch)
treec6e1a4deaca2943a43a9ff6143d778e4a8349a1b /src/Makefile.am
parent71a3e5394346f529ae74e7174dd4156c0229d190 (diff)
downloadayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.tar.gz
ayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.tar.bz2
ayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.zip
add private container struct IndicatorPowerDevice
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e0211a0..d14c270 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,12 +8,16 @@ powerlibdir = $(INDICATORDIR)
powerlib_LTLIBRARIES = libpower.la
libpower_la_SOURCES = \
+ device.c \
indicator-power.c
+noinst_HEADERS = \
+ device.h
+
libpower_la_CFLAGS = \
$(UPOWER_CFLAGS) \
$(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DG_LOG_DOMAIN=\"Indicator-Power\"
@@ -22,7 +26,7 @@ libpower_la_LIBADD = \
$(INDICATOR_LIBS)
libpower_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version