aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-10-15 02:45:50 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-10-15 02:45:50 +0000
commit24966789fc551c90857a848cebae75917fa9cc2d (patch)
tree30fae10e06f643d665a9ff88e9f47f3da63faf45 /tests/CMakeLists.txt
parent7251f3df13dc2503791fc7d1b485a48636a15884 (diff)
parentee53f5d18009dba3cf69ddb2e2135ae2197c43b2 (diff)
downloadayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.tar.gz
ayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.tar.bz2
ayatana-indicator-power-24966789fc551c90857a848cebae75917fa9cc2d.zip
Add mock battery support to make QA testing easier. Fixes: 1373511
Approved by: Antti Kaijanmäki, PS Jenkins bot, Ted Gould
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index a0d24af..02ecb1b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -50,12 +50,3 @@ endfunction()
add_test_by_name(test-notify)
add_test(NAME dear-reader-the-next-test-takes-80-seconds COMMAND true)
add_test_by_name(test-device)
-
-###
-###
-
-set (APP_NAME indicator-power-service-cmdline-battery)
-add_executable (${APP_NAME} ${APP_NAME}.cc device-provider-mock.c)
-add_dependencies (${APP_NAME} libindicatorpowerservice)
-target_link_libraries (${APP_NAME} indicatorpowerservice ${SERVICE_DEPS_LIBRARIES})
-