aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-05-24 09:49:30 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-05-24 09:49:30 -0500
commit622c18549745d3824713fd9d7a4a0d89b31257a5 (patch)
treec6e1a4deaca2943a43a9ff6143d778e4a8349a1b /tests/Makefile.am
parent71a3e5394346f529ae74e7174dd4156c0229d190 (diff)
downloadayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.tar.gz
ayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.tar.bz2
ayatana-indicator-power-622c18549745d3824713fd9d7a4a0d89b31257a5.zip
add private container struct IndicatorPowerDevice
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..87dd606
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,38 @@
+TESTS =
+CLEANFILES =
+check_PROGRAMS =
+
+AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
+AM_CXXFLAGS = $(GTEST_CXXFLAGS)
+
+###
+###
+###
+
+# stock UMB tests on user-visible strings
+include $(srcdir)/Makefile.am.strings
+
+###
+###
+###
+
+TESTS += test-device
+check_PROGRAMS += test-device
+test_device_SOURCES = test-device.cc
+test_device_LDADD = \
+ $(top_builddir)/src/libpower.la \
+ $(INDICATOR_LIBS) \
+ $(UPOWER_LIBS) \
+ $(COVERAGE_LDFLAGS) \
+ libgtest.a
+
+test_device_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(UPOWER_CFLAGS) \
+ $(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS)
+
+check_LIBRARIES = libgtest.a
+nodist_libgtest_a_SOURCES = \
+ $(GTEST_SOURCE)/src/gtest-all.cc \
+ $(GTEST_SOURCE)/src/gtest_main.cc