aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-09-08 22:58:48 -0500
committerTed Gould <ted@gould.cx>2014-09-08 22:58:48 -0500
commit334e3b3130cbde5a96e6da5323d40418db80f8ef (patch)
tree299d5e2a5cdaab892fe7c92b9405f721635124e3 /tests/Makefile.am
parentcc51d0fc02f2980cc08fcd6cfc929ea61ff9d93a (diff)
parent059246d136ed8c24c5e78e6a966bf2dfc945fe4e (diff)
downloadayatana-indicator-power-334e3b3130cbde5a96e6da5323d40418db80f8ef.tar.gz
ayatana-indicator-power-334e3b3130cbde5a96e6da5323d40418db80f8ef.tar.bz2
ayatana-indicator-power-334e3b3130cbde5a96e6da5323d40418db80f8ef.zip
Merge trunk
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am64
1 files changed, 0 insertions, 64 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
deleted file mode 100644
index 5c7d802..0000000
--- a/tests/Makefile.am
+++ /dev/null
@@ -1,64 +0,0 @@
-TESTS =
-CLEANFILES =
-BUILT_SOURCES =
-check_PROGRAMS =
-
-###
-### tests: stock tests on user-visible strings
-###
-
-include $(srcdir)/Makefile.am.strings
-
-###
-### gtest library
-###
-
-check_LIBRARIES = libgtest.a
-nodist_libgtest_a_SOURCES = \
- $(GTEST_SOURCE)/src/gtest-all.cc \
- $(GTEST_SOURCE)/src/gtest_main.cc
-
-AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
-AM_CXXFLAGS = $(GTEST_CXXFLAGS)
-
-###
-### tests: indicator-power-device
-###
-
-TEST_LIBS = $(COVERAGE_LDFLAGS) libgtest.a -lpthread
-TEST_CPPFLAGS = $(SERVICE_DEPS_CFLAGS) $(AM_CPPFLAGS)
-
-TESTS += test-device
-check_PROGRAMS += test-device
-test_device_SOURCES = test-device.cc
-test_device_CPPFLAGS = $(TEST_CPPFLAGS) -Wall -Werror -Wextra
-test_device_LDADD = \
- $(top_builddir)/src/libindicatorpower-service.a \
- $(SERVICE_DEPS_LIBS) \
- $(TEST_LIBS)
-
-
-# (FIXME: incomplete)
-#
-###
-### tests: indicator-power-service
-###
-#
-# build a local copy of the GSettings schemas
-#BUILT_SOURCES += gschemas.compiled
-#CLEANFILES += gschemas.compiled
-#gschemas.compiled: Makefile
-# @glib-compile-schemas --targetdir=$(abs_builddir) $(top_builddir)/data
-#
-#TESTS += test-service
-#check_PROGRAMS += test-service
-#test_service_SOURCES = test-service.cc
-#test_service_LDADD = $(TEST_LIBS)
-#test_service_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""
-#
-#TESTS += test-dbus-listener
-#check_PROGRAMS += test-dbus-listener
-#test_dbus_listener_SOURCES = test-dbus-listener.cc
-#test_dbus_listener_LDADD = $(TEST_LIBS)
-#test_dbus_listener_CPPFLAGS = $(TEST_CPPFLAGS)
-#