aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-03-28 16:10:23 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-03-28 16:10:23 +0000
commit71ef36253e67a4383222b473be3f63188a0452a8 (patch)
tree2c67a4df2c3afb8201490a9b155cc9cb81e210cf /tests/Makefile.am
parent39ab6b3e3687a944f2c41be46bdb5c6259fe838c (diff)
parent8fcb63c1e8fed2988f811c3352efa0077c950162 (diff)
downloadayatana-indicator-power-71ef36253e67a4383222b473be3f63188a0452a8.tar.gz
ayatana-indicator-power-71ef36253e67a4383222b473be3f63188a0452a8.tar.bz2
ayatana-indicator-power-71ef36253e67a4383222b473be3f63188a0452a8.zip
If there are two batteries detected, combine their percentages and their time-remainings as per the revised spec. Fixes: 880881, 1297466
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 47b3e84..483bb8c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,6 +25,13 @@ AM_CXXFLAGS = $(GTEST_CXXFLAGS)
### tests: indicator-power-device
###
+dear-reader-please-note-the-next-test-takes-90-seconds:
+ @echo "#!/bin/bash" > $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+TESTS += dear-reader-please-note-the-next-test-takes-90-seconds
+CLEANFILES += dear-reader-please-note-the-next-test-takes-90-seconds
+
TEST_LIBS = $(COVERAGE_LDFLAGS) libgtest.a -lpthread
TEST_CPPFLAGS = $(SERVICE_DEPS_CFLAGS) $(AM_CPPFLAGS)