aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 15 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 0601c16..aa1cc12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,9 @@
AC_INIT([indicator-power],
- [12.10.6],
+ [13.10.0],
[http://bugs.launchpad.net/indicator-power],
[indicator-power],
[http://launchpad.net/indicator-power])
+AC_COPYRIGHT([Copyright 2011-2013 Canonical])
AC_PREREQ([2.64])
@@ -20,6 +21,7 @@ AM_SILENT_RULES([yes])
AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_CXX
+AM_PROG_AR
# Initialize libtool
LT_PREREQ([2.2.6])
@@ -29,25 +31,20 @@ LT_INIT
###########################
# Dependencies
###########################
+
GLIB_REQUIRED_VERSION=2.35.4
GIO_REQUIRED_VERSION=2.26
-GTK_REQUIRED_VERSION=3.0
-INDICATOR_REQUIRED_VERSION=0.3.90
-UPOWER_REQUIRED_VERSION=0.9.5
+GIO_UNIX_REQUIRED_VERSION=2.26
GSD_REQUIRED_VERSION=3.1.4
-PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
-
-PKG_CHECK_MODULES([INDICATOR],[glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gtk+-3.0 >= $GTK_REQUIRED_VERSION
- indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
-])
-PKG_CHECK_MODULES([GSD],[gnome-settings-daemon >= $GSD_REQUIRED_VERSION])
+PKG_CHECK_MODULES([SERVICE_DEPS],[glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION
+ gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION])
###########################
# GSETTINGS
###########################
+
GLIB_GSETTINGS
###########################
@@ -61,7 +58,6 @@ AC_ARG_ENABLE([tests],
if test "x$enable_tests" != "xno"; then
m4_include([m4/gtest.m4])
CHECK_GTEST
- CHECK_XORG_GTEST
if test "x$enable_tests" = "xauto"; then
enable_tests=${have_gtest}
elif test "x$enable_tests" = "xyes" && test "x$have_gtest" != "xyes"; then
@@ -95,16 +91,13 @@ AC_ARG_ENABLE([localinstall],
[with_localinstall=no])
###########################
-# Indicator Info
+# DBus Service Info
###########################
AS_IF([test "x$with_localinstall" = "xyes"],
- [INDICATORDIR="${libdir}/indicators3/2/"
- INDICATORICONSDIR="${datadir}/indicator-applet/icons/"],
- [INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`])
-AC_SUBST(INDICATORDIR)
-AC_SUBST(INDICATORICONSDIR)
+ [DBUSSERVICEDIR="${datadir}/dbus-1/services/"],
+ [DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`])
+AC_SUBST(DBUSSERVICEDIR)
##############################
# Custom Junk
@@ -126,13 +119,14 @@ AC_DEFUN([AC_DEFINE_PATH], [
# Internationalization
###########################
-IT_PROG_INTLTOOL([0.41.0])
+IT_PROG_INTLTOOL([0.50.0])
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.17])
AC_SUBST([GETTEXT_PACKAGE],[${PACKAGE_TARNAME}])
AC_DEFINE([GETTEXT_PACKAGE],[PACKAGE_TARNAME],[Define to the gettext package name.])
+AC_DEFINE_PATH([GNOMELOCALEDIR],"${datadir}/locale",[locale directory])
###########################
# Files