aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20462fa..84e9423 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,15 @@ AC_ARG_ENABLE([localinstall],
[with_localinstall=$enableval],
[with_localinstall=no])
+###########################
+# DBus Service Info
+###########################
+
+AS_IF([test "x$with_localinstall" = "xyes"],
+ [DBUSSERVICEDIR="${datadir}/dbus-1/services/"],
+ [DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`])
+AC_SUBST(DBUSSERVICEDIR)
+
##############################
# Custom Junk
##############################