aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules9
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index b11fd60..28ab3fd 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends: debhelper (>= 9),
libglib2.0-dev (>= 2.36),
libgudev-1.0-dev,
liburl-dispatcher1-dev,
- python,
+ python:any,
Standards-Version: 3.9.2
Homepage: https://launchpad.net/indicator-power
# If you aren't a member of ~indicator-applet-developers but need to upload
diff --git a/debian/rules b/debian/rules
index 83edd94..36a22d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,21 @@
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ TESTS=yes
+else
+ TESTS=no
+endif
+
%:
dh $@ --with autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-tests=$(TESTS)
+
override_dh_install:
find debian/indicator-power -name \*.la -delete
find debian/indicator-power -name \*.a -delete