aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e0211a0..d14c270 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,12 +8,16 @@ powerlibdir = $(INDICATORDIR)
powerlib_LTLIBRARIES = libpower.la
libpower_la_SOURCES = \
+ device.c \
indicator-power.c
+noinst_HEADERS = \
+ device.h
+
libpower_la_CFLAGS = \
$(UPOWER_CFLAGS) \
$(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DG_LOG_DOMAIN=\"Indicator-Power\"
@@ -22,7 +26,7 @@ libpower_la_LIBADD = \
$(INDICATOR_LIBS)
libpower_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version