aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2021-12-07 21:47:00 +0100
committerLuca Weiss <luca@z3ntu.xyz>2021-12-07 21:47:02 +0100
commitb4e36f43ec5ef68b05679a21c3a67ccc811034eb (patch)
treeff817f1016a208ddeb1319c0e574eee09b8074de /configure.ac
parent5af74774d0e9130d291094988c98f3e9544edfa8 (diff)
downloadayatana-indicator-printers-b4e36f43ec5ef68b05679a21c3a67ccc811034eb.tar.gz
ayatana-indicator-printers-b4e36f43ec5ef68b05679a21c3a67ccc811034eb.tar.bz2
ayatana-indicator-printers-b4e36f43ec5ef68b05679a21c3a67ccc811034eb.zip
Remove bash-ism from configure.ac
The += operator is not available e.g. in busybox ash. Instead of trying to extend CUPS_CFLAGS and _LIBS, we can just set them as nothing sets them beforehand.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0986f8c..8919cfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,8 +50,8 @@ if test "x$CUPS_CONFIG" = "xno"; then
AC_MSG_ERROR([could not find cups-config])
fi
AC_CHECK_HEADER(cups/cups.h,,AC_MSG_ERROR([could not find cups.h]))
-CUPS_CFLAGS+=`$CUPS_CONFIG --cflags`
-CUPS_LIBS+=`$CUPS_CONFIG --libs`
+CUPS_CFLAGS=`$CUPS_CONFIG --cflags`
+CUPS_LIBS=`$CUPS_CONFIG --libs`
SERVICE_CFLAGS="$SERVICE_CFLAGS $CUPS_CFLAGS"
SERVICE_LIBS="$SERVICE_LIBS $CUPS_LIBS"