aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-01-26 19:44:53 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-01-26 19:44:53 +0100
commitbf2ef61757ee6bda275769e25907fc0a148038c2 (patch)
treefb7756f858c05074c9190ef3488c8582b03ec99f /configure.ac
parent0834e6f4d7aa6499a6657296ea013a4c0fe8190e (diff)
downloadayatana-indicator-printers-bf2ef61757ee6bda275769e25907fc0a148038c2.tar.gz
ayatana-indicator-printers-bf2ef61757ee6bda275769e25907fc0a148038c2.tar.bz2
ayatana-indicator-printers-bf2ef61757ee6bda275769e25907fc0a148038c2.zip
Initialize the menu with job list from cups when starting the service
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3c9160f..912b9fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,14 @@ PKG_CHECK_MODULES(SERVICE, gtk+-3.0 >= 3.0
indicator3-0.4 >= 0.2
dbusmenu-glib-0.4 >= 0.2)
+AC_PATH_PROG(CUPS_CONFIG, cups-config, no)
+if test "x$CUPS_CONFIG" = "xno"; then
+ AC_MSG_ERROR([could not find cups-config])
+fi
+AC_CHECK_HEADER(cups/cups.h,,AC_MSG_ERROR([could not find cups.h]))
+SERVICE_CFLAGS+=`$CUPS_CONFIG --cflags`
+SERVICE_LIBS+=`$CUPS_CONFIG --libs`
+
INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`