aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:45:14 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:45:14 +0200
commit33b9b08f8d1df1dc3000706571a653482002800d (patch)
tree9e0c4e2122aa36b965535e07f9196f6ae7a4f2e7 /data/Makefile.am
parent55393ea5222eb3197f33f66cd4683396b84b811f (diff)
downloadayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.tar.gz
ayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.tar.bz2
ayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.zip
Revert "Remove old autostart files."
This reverts commit fcbd561ad7ecbc0d7273facf6185c7364192cd88.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 75bb04b..08b87ea 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -2,6 +2,8 @@ BUILT_SOURCES=
CLEANFILES=
EXTRA_DIST=
+SUBDIRS = upstart
+
#
# the systemd unit file
#
@@ -38,5 +40,19 @@ BUILT_SOURCES += $(upstart_jobs_DATA)
CLEANFILES += $(upstart_jobs_DATA)
EXTRA_DIST += $(upstart_jobs_in)
+#
+# the xdg autostart job file
+#
+
+xdg_autostartdir = /etc/xdg/autostart
+xdg_autostart_DATA = indicator-printers.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+
DISTCLEANFILES = \
Makefile.in
+