aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-25 16:27:11 +0000
committerTarmac <Unknown>2014-02-25 16:27:11 +0000
commit464ad34b13d3ef60265b6c22bdf608bab334309a (patch)
tree5cde744452847515406e3210d41d005f57b2da4d /data/upstart/Makefile.am
parent4a7d3578994939cfcf1e3c0f4eb213d2f97d9496 (diff)
parent2fa7d7ac75aabdb501c700679a995d0a32691b80 (diff)
downloadayatana-indicator-printers-464ad34b13d3ef60265b6c22bdf608bab334309a.tar.gz
ayatana-indicator-printers-464ad34b13d3ef60265b6c22bdf608bab334309a.tar.bz2
ayatana-indicator-printers-464ad34b13d3ef60265b6c22bdf608bab334309a.zip
Synchronize process management across indicators.
Approved by Charles Kerr, PS Jenkins bot.
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..8eb41e9
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,17 @@
+BUILT_SOURCES=
+CLEANFILES=
+EXTRA_DIST=
+
+#
+# the upstart xdg autostart override
+#
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-printers.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+