aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:45:14 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 22:45:14 +0200
commit33b9b08f8d1df1dc3000706571a653482002800d (patch)
tree9e0c4e2122aa36b965535e07f9196f6ae7a4f2e7 /data/upstart/Makefile.am
parent55393ea5222eb3197f33f66cd4683396b84b811f (diff)
downloadayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.tar.gz
ayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.tar.bz2
ayatana-indicator-printers-33b9b08f8d1df1dc3000706571a653482002800d.zip
Revert "Remove old autostart files."
This reverts commit fcbd561ad7ecbc0d7273facf6185c7364192cd88.
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..8eb41e9
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,17 @@
+BUILT_SOURCES=
+CLEANFILES=
+EXTRA_DIST=
+
+#
+# the upstart xdg autostart override
+#
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-printers.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+