aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-20 10:06:20 -0600
committerTed Gould <ted@gould.cx>2014-02-20 10:06:20 -0600
commitd75744cc260d74e7ef010ca355b4051496a8ed9b (patch)
tree1b6b4b5022bd21e7d29a56a1a6748419bc283c85 /data/upstart/Makefile.am
parent3bcbc85d8cda75d56101123ee9daf261b15c90fb (diff)
downloadayatana-indicator-printers-d75744cc260d74e7ef010ca355b4051496a8ed9b.tar.gz
ayatana-indicator-printers-d75744cc260d74e7ef010ca355b4051496a8ed9b.tar.bz2
ayatana-indicator-printers-d75744cc260d74e7ef010ca355b4051496a8ed9b.zip
Adding in Upstart XDG override
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..8eb41e9
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,17 @@
+BUILT_SOURCES=
+CLEANFILES=
+EXTRA_DIST=
+
+#
+# the upstart xdg autostart override
+#
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-printers.desktop
+xdg_autostart_in = $(xdg_autostart_DATA:.desktop=.desktop.in)
+$(xdg_autostart_DATA): $(xdg_autostart_in)
+ $(AM_V_GEN) $(SED) -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+BUILT_SOURCES += $(xdg_autostart_DATA)
+CLEANFILES += $(xdg_autostart_DATA)
+EXTRA_DIST += $(xdg_autostart_in)
+