aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 19:41:24 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-10-24 19:41:24 +0200
commit2a0c152f523ce964572f3f9f318dac263e52079f (patch)
treeda09f6b1815d42eb3b9d60a15324db04ef0cc907 /debian/rules
parent5899afa3fa9f42532ac3afb1beefe9204104d225 (diff)
downloadayatana-indicator-printers-2a0c152f523ce964572f3f9f318dac263e52079f.tar.gz
ayatana-indicator-printers-2a0c152f523ce964572f3f9f318dac263e52079f.tar.bz2
ayatana-indicator-printers-2a0c152f523ce964572f3f9f318dac263e52079f.zip
Fork from Ubuntu's indicator-printers.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 12 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index c8c6a4b..c339196 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -7,16 +10,19 @@ LDFLAGS += -Wl,-z,defs -Wl,--as-needed
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
%:
- dh $@ --with autoreconf,translations
-
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+ dh $@ --without autoreconf
override_dh_auto_configure:
+ NOCONFIGURE=1 ./autogen.sh
dh_auto_configure -- \
--disable-static
override_dh_install:
- find debian/indicator-printers -name \*.la -delete
- find debian/indicator-printers -name \*.a -delete
+ find debian/ayatana-indicator-printers -name \*.la -delete
+ find debian/ayatana-indicator-printers -name \*.a -delete
dh_install --fail-missing
+
+override_dh_auto_clean:
+ dh_auto_clean
+ # no clue, why they don't disappear during make distclean...
+ rm -f config.sub config.guess