aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-02-16 21:34:57 +0100
committerSebastien Bacher <seb128@ubuntu.com>2012-02-16 21:34:57 +0100
commitcd4ca90b9de81d4a0430ad7782477f62035f5bbe (patch)
tree6df904e1443cc4e5263dbcd0b8c4c9aa8959a9ad /test/Makefile.am
parent1204ca2827e64aa041b4bd36813be3d70db54802 (diff)
parentf35cbc8ebf673ca3308eb20fb5409c76e78de0ff (diff)
downloadayatana-indicator-printers-cd4ca90b9de81d4a0430ad7782477f62035f5bbe.tar.gz
ayatana-indicator-printers-cd4ca90b9de81d4a0430ad7782477f62035f5bbe.tar.bz2
ayatana-indicator-printers-cd4ca90b9de81d4a0430ad7782477f62035f5bbe.zip
releasing version 0.1.1-0ubuntu1
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index d3e10bb..4084cba 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -2,10 +2,21 @@
noinst_PROGRAMS = mock-cups-notifier
DISTCLEANFILES = mock-cups-notifier
+cups_notifier_sources = \
+ cups-notifier.c \
+ cups-notifier.h
+
+$(cups_notifier_sources): $(top_srcdir)/src/org.cups.cupsd.Notifier.xml
+ gdbus-codegen \
+ --interface-prefix org.cups.cupsd \
+ --c-namespace Cups \
+ --generate-c-code cups-notifier \
+ $^
+
mock_cups_notifier_SOURCES = \
- mock-cups-notifier.c \
- $(top_builddir)/src/cups-notifier.c \
- $(top_builddir)/src/cups-notifier.h
+ mock-cups-notifier.c
+
+nodist_mock_cups_notifier_SOURCES = $(cups_notifier_sources)
mock_cups_notifier_CPPFLAGS = \
$(SERVICE_CFLAGS) \
@@ -13,3 +24,6 @@ mock_cups_notifier_CPPFLAGS = \
mock_cups_notifier_LDADD = $(SERVICE_LIBS)
+BUILT_SOURCES = $(cups_notifier_sources)
+CLEANFILES = $(BUILT_SOURCES)
+