aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c032912
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+
+CFLAGS += -Wno-error=deprecated-declarations
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-static
+
+override_dh_install:
+ find debian/indicator-printers -name \*.la -delete
+ find debian/indicator-printers -name \*.a -delete
+ dh_install --fail-missing