aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2011-08-22 13:32:00 +0100
committerConor Curran <conor.curran@canonical.com>2011-08-22 13:32:00 +0100
commit397ce19ba4e460dbb3bfb4a4b7b06d98918c153b (patch)
treef1c03f830718148fc7184cf0e4240b874b82f07d /Makefile.am
parent3dd1acc6b1514a255179e29642bc5b9929b80cff (diff)
parent6dc0245f7ec5015a5e2e7a19994b3d417aeb9867 (diff)
downloadayatana-indicator-session-397ce19ba4e460dbb3bfb4a4b7b06d98918c153b.tar.gz
ayatana-indicator-session-397ce19ba4e460dbb3bfb4a4b7b06d98918c153b.tar.bz2
ayatana-indicator-session-397ce19ba4e460dbb3bfb4a4b7b06d98918c153b.zip
ellipsis fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 391ff49..5850769 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,3 +33,15 @@ dist-hook:
else \
echo Failed to generate AUTHORS: not a branch >&2; \
fi
+
+TESTS = \
+ test-ellipsis
+
+test-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.*\.\.\.\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+CLEANFILES = $(TESTS)