aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-08-23 16:30:22 -0500
committerTed Gould <ted@gould.cx>2011-08-23 16:30:22 -0500
commitabc80c0b8b86e4bae570c834ff99c30356399897 (patch)
treec35b16bfb925833e8fd3030ee08ef07b001fddb4 /Makefile.am
parent78a38ad242c381e7bf37e1a91897dbc61f5e5b65 (diff)
downloadayatana-indicator-session-abc80c0b8b86e4bae570c834ff99c30356399897.tar.gz
ayatana-indicator-session-abc80c0b8b86e4bae570c834ff99c30356399897.tar.bz2
ayatana-indicator-session-abc80c0b8b86e4bae570c834ff99c30356399897.zip
Adding a test to look for various ASCII quotes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7211fab..d63dac8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,8 @@ dist-hook:
TESTS = \
test-ellipsis \
- test-space-ellipsis
+ test-space-ellipsis \
+ test-ascii-quotes
#####
# Tests for there being proper ellipsis instead of three periods in a row
@@ -58,4 +59,16 @@ test-space-ellipsis: po
@echo "exit 0" >> $@
@chmod +x $@
+#####
+# Tests for ASCII quote types
+#####
+test-ascii-quotes: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid \\\".*'.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII apostrophy found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\".*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII quote found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\`.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII backtick found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
CLEANFILES = $(TESTS)