aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-08-23 11:24:46 -0500
committerTed Gould <ted@gould.cx>2011-08-23 11:24:46 -0500
commitb0eef117956490d332413394adb4bfec13218d8e (patch)
treed2c577e6d9ba86970b46d7d26a1616f19332a572 /Makefile.am
parent4a40fcc027093f4f5c890036c56960b5ef918e19 (diff)
parente6492845f60367ddbaea1ffae359a8b5e2364075 (diff)
downloadayatana-indicator-session-b0eef117956490d332413394adb4bfec13218d8e.tar.gz
ayatana-indicator-session-b0eef117956490d332413394adb4bfec13218d8e.tar.bz2
ayatana-indicator-session-b0eef117956490d332413394adb4bfec13218d8e.zip
* Upstream Merge
* So much stuff... * Desktop files for system functions
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 391ff49..5850769 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,3 +33,15 @@ dist-hook:
else \
echo Failed to generate AUTHORS: not a branch >&2; \
fi
+
+TESTS = \
+ test-ellipsis
+
+test-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.*\.\.\.\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+CLEANFILES = $(TESTS)