aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-04-26 15:01:53 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-04-26 15:01:53 -0500
commit6187dfbd140c6f3af8dce96c3cac1e86c6ff0442 (patch)
treed15d69d21741b04cbaeecaecee63f1378e818998 /Makefile.am
parent705eb1b42bd83149592a284a035b54c3346936da (diff)
downloadayatana-indicator-session-6187dfbd140c6f3af8dce96c3cac1e86c6ff0442.tar.gz
ayatana-indicator-session-6187dfbd140c6f3af8dce96c3cac1e86c6ff0442.tar.bz2
ayatana-indicator-session-6187dfbd140c6f3af8dce96c3cac1e86c6ff0442.zip
only require GTest and libdbustest if we're building the unit tests
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b76302c..c05a4f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,9 +2,14 @@
SUBDIRS = \
src \
data \
- tests \
po
+if BUILD_TESTS
+SUBDIRS += tests
+# build src first
+test: src
+endif
+
EXTRA_DIST = autogen.sh
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall