aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-08-25 09:03:29 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-08-25 09:03:29 -0400
commit6bacf14ef210f0ff8a2cc179f235d70906485698 (patch)
tree3d4b01e0562a1c44e396ce0a45004d618757728d /Makefile.am
parent92cb2ff94b4efb98437639a7c37fa894efa03556 (diff)
parentce36ed0c35e58f0244a090250ab7f96b8e5915ac (diff)
downloadayatana-indicator-session-6bacf14ef210f0ff8a2cc179f235d70906485698.tar.gz
ayatana-indicator-session-6bacf14ef210f0ff8a2cc179f235d70906485698.tar.bz2
ayatana-indicator-session-6bacf14ef210f0ff8a2cc179f235d70906485698.zip
* New upstream release.
- User menu should still show even if there is only 1 user (LP: #831758) - Bluetooth item in menu not needed (LP: #825111) - Newly created users are not added to the menu until next login (LP: #552048) - Users list in shutdown menu is not updated on user deletion (LP: #557608) - should use gsettings rather than gconf (LP: #656323)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 391ff49..d63dac8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,3 +33,42 @@ dist-hook:
else \
echo Failed to generate AUTHORS: not a branch >&2; \
fi
+
+TESTS = \
+ test-ellipsis \
+ test-space-ellipsis \
+ test-ascii-quotes
+
+#####
+# Tests for there being proper ellipsis instead of three periods in a row
+#####
+test-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.*\.\.\.\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+#####
+# Tests for there being a space before an ellipsis
+#####
+test-space-ellipsis: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid.* …\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"Space before ellipsis found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+#####
+# Tests for ASCII quote types
+#####
+test-ascii-quotes: po
+ @echo "#!/bin/bash" > $@
+ @echo "(cd po && make $(GETTEXT_PACKAGE).pot)" >> $@
+ @echo "grep -c -e \"^msgid \\\".*'.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII apostrophy found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\".*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII quote found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "grep -c -e \"^msgid \\\".*\\\`.*\\\"\" po/$(GETTEXT_PACKAGE).pot > /dev/null && echo \"ASCII backtick found in user visible strings\" >&2 && exit 1" >> $@
+ @echo "exit 0" >> $@
+ @chmod +x $@
+
+CLEANFILES = $(TESTS)