aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-06-10 09:48:51 -0500
committerTed Gould <ted@canonical.com>2009-06-10 09:48:51 -0500
commit4a3887142581168e9eda220bd22c1b9f10073fd1 (patch)
treea7cbf6b80689e85a67ca6f7e79d27a3d3afae472 /configure.ac
parentb00bec83c75676a02eb6bebc2c51d5f0376dcf34 (diff)
downloadayatana-indicator-session-4a3887142581168e9eda220bd22c1b9f10073fd1.tar.gz
ayatana-indicator-session-4a3887142581168e9eda220bd22c1b9f10073fd1.tar.bz2
ayatana-indicator-session-4a3887142581168e9eda220bd22c1b9f10073fd1.zip
Adding a configure flag so that indicators can be installed locally for distcheck purposes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1d86cac..4d656c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,10 +49,21 @@ AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
###########################
+# Check to see if we're local
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+
+###########################
# Indicator Info
###########################
-INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+if test "x$with_localinstall" = "xyes"; then
+ INDICATORDIR="${libdir}/indicators/2/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+fi
AC_SUBST(INDICATORDIR)
###########################