aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-06-09 16:53:00 -0500
committerTed Gould <ted@canonical.com>2009-06-09 16:53:00 -0500
commitee013228b486d5b49be2737e90f3e75aded90365 (patch)
tree0ccf93c16d3bac4cca194bbdbe244b841b3c9176 /configure.ac
parent49c4646f0d2beb676e6d60d971fe7789253c4f38 (diff)
downloadayatana-indicator-session-ee013228b486d5b49be2737e90f3e75aded90365.tar.gz
ayatana-indicator-session-ee013228b486d5b49be2737e90f3e75aded90365.tar.bz2
ayatana-indicator-session-ee013228b486d5b49be2737e90f3e75aded90365.zip
Adding more dependencies and cflags and stuff to make the builds of the services more complete
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 742403a..1d86cac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,23 @@ PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
+DBUSMENUGLIB_REQUIRED_VERSION=0.0.0
+
+PKG_CHECK_MODULES(STATUSSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(STATUSERVICE_CFLAGS)
+AC_SUBST(STATUSERVICE_LIBS)
+
+PKG_CHECK_MODULES(USERSSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(USERSERVICE_CFLAGS)
+AC_SUBST(USERSERVICE_LIBS)
+
+PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(SESSIONERVICE_CFLAGS)
+AC_SUBST(SESSIONERVICE_LIBS)
+
###########################
# Indicator Info
###########################