aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeni Golov <evgeni@debian.org>2012-02-23 00:20:15 +0100
committerEvgeni Golov <evgeni@debian.org>2012-02-23 00:20:15 +0100
commit05f7c359ae59cbcf9890dddf27dd4362269459c8 (patch)
treec722805bbfa2a3e405d5aaf538f87840b3112546 /configure.ac
parent13d6c2bd152c5c9de79537f541f687e3dcd8ba7b (diff)
downloadayatana-indicator-session-05f7c359ae59cbcf9890dddf27dd4362269459c8.tar.gz
ayatana-indicator-session-05f7c359ae59cbcf9890dddf27dd4362269459c8.tar.bz2
ayatana-indicator-session-05f7c359ae59cbcf9890dddf27dd4362269459c8.zip
make gudev dep optional
Debian has arches w/o udev (hurd-*, kfreebsd-*). These cannot build indicator-session currently because libgudev-1.0-dev is missing there. Make the gudev dep optional and thus make indicator-session buildable on non-Linux arches again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8d02d69..0c2a9f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,6 @@ AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
dbus-glib-1
- gudev-1.0
gio-unix-2.0
indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
packagekit-glib2)
@@ -69,7 +68,6 @@ AS_IF([test "x$with_gtk" = x3],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- gudev-1.0
dbus-glib-1
gio-unix-2.0
indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
@@ -80,6 +78,10 @@ AS_IF([test "x$with_gtk" = x3],
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
+PKG_CHECK_MODULES(GUDEV, gudev-1.0, has_gudev=true, has_gudev=false)
+AC_SUBST(GUDEV_CFLAGS)
+AC_SUBST(GUDEV_LIBS)
+
AM_CONDITIONAL([USE_GTK3], [test "x$with_gtk" = "x3"])
AS_IF([test "x$with_gtk" = x3], [
AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
@@ -199,7 +201,9 @@ AM_GLIB_GNU_GETTEXT
# Files
###########################
-AC_OUTPUT([
+AM_CONDITIONAL([HAS_GUDEV], [test "x$has_gudev" = "xtrue"])
+
+AC_CONFIG_FILES([
Makefile
src/Makefile
data/Makefile
@@ -223,6 +227,8 @@ data/extra-sessions/Makefile
po/Makefile.in
])
+AC_OUTPUT
+
###########################
# Results
###########################