aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2012-02-08 17:30:50 +0000
committerConor Curran <conor.curran@canonical.com>2012-02-08 17:30:50 +0000
commit3b8d13f352d76bae85dcff763af583927fdaaad7 (patch)
tree42e684a9682fbe900684e22e059b713c3406ba30 /configure.ac
parent4145c29279197d5985d348fbe2ef219a4c015a11 (diff)
parent6975e8a7aab320c77f3cb3de345415b9f26ba5cd (diff)
downloadayatana-indicator-session-3b8d13f352d76bae85dcff763af583927fdaaad7.tar.gz
ayatana-indicator-session-3b8d13f352d76bae85dcff763af583927fdaaad7.tar.bz2
ayatana-indicator-session-3b8d13f352d76bae85dcff763af583927fdaaad7.zip
properly fix conflict and make sure to not check for updates 1 minute after starting the service or Pitti will kill me :)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52a54b9..7fa6b48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_INIT(src/indicator-session.c)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-session, 0.3.7.1)
+AM_INIT_AUTOMAKE(indicator-session, 0.3.90)
AM_MAINTAINER_MODE
@@ -51,6 +51,7 @@ AS_IF([test "x$with_gtk" = x3],
],
[AC_MSG_FAILURE([Value for --with-indicator-gtk was neither 2 nor 3])]
)
+
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
@@ -79,6 +80,11 @@ AS_IF([test "x$with_gtk" = x3],
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
+AM_CONDITIONAL([USE_GTK3], [test "x$with_gtk" = "x3"])
+AS_IF([test "x$with_gtk" = x3], [
+ AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
+ ])
+
###########################
# GTK Logout Helper
###########################