aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGyörgy Balló <ballogy@freestart.hu>2011-11-23 22:58:41 +0100
committerGyörgy Balló <ballogy@freestart.hu>2011-11-23 22:58:41 +0100
commit5a3df0dde62593659e792f92236a8142087080f7 (patch)
tree52fd1d3c6d8072e8d21eecb8428c279c107e4dad /configure.ac
parentf2b3d4838b6a175458f903aeb8a8d04fe7a842a5 (diff)
downloadayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.tar.gz
ayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.tar.bz2
ayatana-indicator-session-5a3df0dde62593659e792f92236a8142087080f7.zip
Make GTK Logout Helper optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 32 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 0e20a91..a6ea42f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,16 +77,38 @@ AS_IF([test "x$with_gtk" = x3],
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
-AS_IF([test "x$with_gtk" = x3],
- [PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
- ],
- [test "x$with_gtk" = x2],
- [PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-2.0 >= $GTK_REQUIRED_VERSION
- polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
- ]
-)
+###########################
+# GTK Logout Helper
+###########################
+AC_ARG_ENABLE([gtklogouthelper],
+ AS_HELP_STRING([--enable-gtklogouthelper], [enable GTK Logout Helper]),,
+ enable_gtklogouthelper=auto)
+
+if test x"$enable_gtklogouthelper" != x"no" ; then
+ AS_IF([test "x$with_gtk" = x3],
+ [PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
+ [have_gtklogouthelper=yes],
+ [have_gtklogouthelper=no])
+ ],
+ [test "x$with_gtk" = x2],
+ [PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION,
+ [have_gtklogouthelper=yes],
+ [have_gtklogouthelper=no])
+ ]
+ )
+ if test x${have_gtklogouthelper} = xyes; then
+ AC_DEFINE(HAVE_GTKLOGOUTHELPER, 1, [Define to 1 to enable GTK Logout Helper])
+ fi
+ if test x${enable_gtklogouthelper} = xyes && test x${have_gtklogouthelper} = xno; then
+ AC_MSG_ERROR([GTK Logout Helper configured but polkit-gobject not found])
+ fi
+else
+ have_gtklogouthelper=no
+fi
+AM_CONDITIONAL(BUILD_GTKLOGOUTHELPER, test x${have_gtklogouthelper} = xyes)
AC_SUBST(GTKLOGOUTHELPER_CFLAGS)
AC_SUBST(GTKLOGOUTHELPER_LIBS)
@@ -192,4 +214,5 @@ SUS Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
Indicator GTK: $with_gtk
+ Logout Helper: $have_gtklogouthelper
])