aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-07-26 23:47:27 -0500
committerTed Gould <ted@canonical.com>2009-07-26 23:47:27 -0500
commit9b7303cd469357b2d17cb87313d83d47ffc16470 (patch)
tree3248af69a8fb6f5791ff48aa1cd30d24146ec556 /configure.ac
parentf5cec7c3e6dc602772642bd390ec632450709145 (diff)
parent0417e7049a32ceb45e19705992dfccef5d858893 (diff)
downloadayatana-indicator-session-9b7303cd469357b2d17cb87313d83d47ffc16470.tar.gz
ayatana-indicator-session-9b7303cd469357b2d17cb87313d83d47ffc16470.tar.bz2
ayatana-indicator-session-9b7303cd469357b2d17cb87313d83d47ffc16470.zip
Merging in the branch to port everything to libindicator and fleshing thigns out.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 62 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ec22ca2..1e65958 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_INIT(src/indicator-fusa.c)
+AC_INIT(src/indicator-sus.c)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-fusa, 0.1)
+AM_INIT_AUTOMAKE(indicator-sus, 0.1dev)
AM_MAINTAINER_MODE
@@ -22,12 +22,67 @@ AC_CONFIG_MACRO_DIR([m4])
###########################
GTK_REQUIRED_VERSION=2.12
-PANEL_REQUIRED_VERSION=2.0.0
+INDICATOR_REQUIRED_VERSION=0.2.0
+DBUSMENUGTK_REQUIRED_VERSION=0.0.0
-PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION)
+PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ indicator >= $INDICATOR_REQUIRED_VERSION
+ dbusmenu-gtk >= $DBUSMENUGTK_REQUIRED_VERSION)
AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
+DBUSMENUGLIB_REQUIRED_VERSION=0.0.0
+
+PKG_CHECK_MODULES(STATUSSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(STATUSERVICE_CFLAGS)
+AC_SUBST(STATUSERVICE_LIBS)
+
+PKG_CHECK_MODULES(USERSSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(USERSERVICE_CFLAGS)
+AC_SUBST(USERSERVICE_LIBS)
+
+PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib >= $DBUSMENUGLIB_REQUIRED_VERSION)
+
+AC_SUBST(SESSIONERVICE_CFLAGS)
+AC_SUBST(SESSIONERVICE_LIBS)
+
+PKG_CHECK_MODULES(GTKLOGOUTHELPER, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ polkit-gnome)
+
+AC_SUBST(GTKLOGOUTHELPER_CFLAGS)
+AC_SUBST(GTKLOGOUTHELPER_LIBS)
+
+###########################
+# Check to see if we're local
+###########################
+
+with_localinstall="no"
+AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
+
+###########################
+# Indicator Info
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ INDICATORDIR="${libdir}/indicators/2/"
+else
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
+fi
+AC_SUBST(INDICATORDIR)
+
+###########################
+# DBus Service Info
+###########################
+
+if test "x$with_localinstall" = "xyes"; then
+ DBUSSERVICEDIR="${datadir}/dbus-1/services/"
+else
+ DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
+fi
+AC_SUBST(DBUSSERVICEDIR)
+
###########################
# Files
###########################
@@ -35,6 +90,8 @@ AC_SUBST(APPLET_LIBS)
AC_OUTPUT([
Makefile
src/Makefile
+src/gtk-dialog/Makefile
+data/Makefile
])
###########################
@@ -43,7 +100,7 @@ src/Makefile
AC_MSG_NOTICE([
-FUSA Indicator Configuration:
+SUS Indicator Configuration:
Prefix: $prefix
])