aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-27 17:29:55 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-27 17:29:55 -0500
commitd9416f4f284c401b8848e4bd249fd5cbd25142c3 (patch)
tree952be03ae1947709564ed479da10d13534cf692a /configure.ac
parent3c5b15aba9bb40ab8ef9c55df35941b67e52d31b (diff)
downloadayatana-indicator-session-d9416f4f284c401b8848e4bd249fd5cbd25142c3.tar.gz
ayatana-indicator-session-d9416f4f284c401b8848e4bd249fd5cbd25142c3.tar.bz2
ayatana-indicator-session-d9416f4f284c401b8848e4bd249fd5cbd25142c3.zip
Added gcov coverage tooling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ab12f12..a6a7b05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,18 @@ AC_DEFINE_PATH(GNOMELOCALEDIR, "${datadir}/locale", [locale directory])
AM_GLIB_GNU_GETTEXT
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -237,9 +249,10 @@ AC_MSG_NOTICE([
SUS Indicator Configuration:
- Prefix: $prefix
- Indicator Dir: $INDICATORDIR
- Indicator GTK: $with_gtk
- Logout Helper: $have_gtklogouthelper
- APT support: $enable_apt
+ Prefix: $prefix
+ Indicator Dir: $INDICATORDIR
+ Indicator GTK: $with_gtk
+ Logout Helper: $have_gtklogouthelper
+ APT support: $enable_apt
+ Coverage reporting: $use_gcov
])