aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-23 08:42:27 -0600
committerTed Gould <ted@gould.cx>2012-02-23 08:42:27 -0600
commit8125b675b131f6599b0c9a8ed0c041f24533f76d (patch)
tree09fbb7903aaa06514ef04e11b0fc04648e086128 /configure.ac
parent7609f062397a3f33fa6587972e200edefa5e7222 (diff)
parent68cf3cfad3861048d620b2486abf47d5a3ce2886 (diff)
downloadayatana-indicator-session-8125b675b131f6599b0c9a8ed0c041f24533f76d.tar.gz
ayatana-indicator-session-8125b675b131f6599b0c9a8ed0c041f24533f76d.tar.bz2
ayatana-indicator-session-8125b675b131f6599b0c9a8ed0c041f24533f76d.zip
Make GUDev optional for arch's that can't support it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8d02d69..0c2a9f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,6 @@ AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
dbus-glib-1
- gudev-1.0
gio-unix-2.0
indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
packagekit-glib2)
@@ -69,7 +68,6 @@ AS_IF([test "x$with_gtk" = x3],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(SESSIONSERVICE, dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- gudev-1.0
dbus-glib-1
gio-unix-2.0
indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
@@ -80,6 +78,10 @@ AS_IF([test "x$with_gtk" = x3],
AC_SUBST(SESSIONERVICE_CFLAGS)
AC_SUBST(SESSIONERVICE_LIBS)
+PKG_CHECK_MODULES(GUDEV, gudev-1.0, has_gudev=true, has_gudev=false)
+AC_SUBST(GUDEV_CFLAGS)
+AC_SUBST(GUDEV_LIBS)
+
AM_CONDITIONAL([USE_GTK3], [test "x$with_gtk" = "x3"])
AS_IF([test "x$with_gtk" = x3], [
AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
@@ -199,7 +201,9 @@ AM_GLIB_GNU_GETTEXT
# Files
###########################
-AC_OUTPUT([
+AM_CONDITIONAL([HAS_GUDEV], [test "x$has_gudev" = "xtrue"])
+
+AC_CONFIG_FILES([
Makefile
src/Makefile
data/Makefile
@@ -223,6 +227,8 @@ data/extra-sessions/Makefile
po/Makefile.in
])
+AC_OUTPUT
+
###########################
# Results
###########################