aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-06 20:14:53 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-11-06 20:14:53 -0600
commit0b63ef0ea8625d713b9f726c8d664fdbeb37481d (patch)
treefbd3559a9a5d326c2257f3e695a36be340773787 /configure.ac
parentccc363f909fc8e2ecc571e83e18c12f46b771c1c (diff)
downloadayatana-indicator-session-0b63ef0ea8625d713b9f726c8d664fdbeb37481d.tar.gz
ayatana-indicator-session-0b63ef0ea8625d713b9f726c8d664fdbeb37481d.tar.bz2
ayatana-indicator-session-0b63ef0ea8625d713b9f726c8d664fdbeb37481d.zip
Reimplement test-service s.t. we actually test activating the service via dbus. Drop unneeded Xorg baggage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3de4063..bb46782 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
# Dependencies
###########################
+GIO_REQUIRED_VERSION=2.33
GLIB_REQUIRED_VERSION=2.33
GTK_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.19
@@ -138,16 +139,15 @@ if test "x$enable_tests" != "xno"; then
AC_MSG_ERROR([tests were requested but gtest is not installed.])
fi
if test "x$enable_tests" = "xyes"; then
- PKG_CHECK_MODULES([TEST_SERVICE],[indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
- dbustest-1 >= $DBUSTEST_REQUIRED_VERSION
- dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION],
- [enable_tests="yes"],
- [enable_tests="no"])
+ PKG_CHECK_MODULES([TEST_SERVICE],[glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION],
+ [enable_tests="yes"],
+ [enable_tests="no"])
fi
fi
AM_CONDITIONAL([BUILD_TESTS],[test "x$enable_tests" = "xyes"])
AC_SUBST([TEST_SERVICE_CFLAGS])
-AC_SUBST([TEST_SERVICE_LDFLAGS])
+AC_SUBST([TEST_SERVICE_LIBS])
##############################
# Custom Junk
@@ -214,6 +214,7 @@ data/icons/scalable/actions/Makefile
data/icons/scalable/status/Makefile
data/extra-sessions/Makefile
tests/Makefile
+tests/indicator-session.service
po/Makefile.in
])