aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-07-06 15:11:40 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-07-06 15:11:40 -0500
commit28eebe0162f5caf8fec30e49291f81f48f118818 (patch)
tree65fc1c174e0e90f2714400a0445b389523195077 /configure.ac
parent1f437a24a3eff6be73d29cc7b1ed602a244e89d2 (diff)
downloadayatana-indicator-session-28eebe0162f5caf8fec30e49291f81f48f118818.tar.gz
ayatana-indicator-session-28eebe0162f5caf8fec30e49291f81f48f118818.tar.bz2
ayatana-indicator-session-28eebe0162f5caf8fec30e49291f81f48f118818.zip
if tests aren't explicitly requested, don't fail the build if dbus-test-runner isn't installed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8d2d901..73f7a55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,7 +137,9 @@ if test "x$enable_tests" != "xno"; then
if test "x$enable_tests" = "xyes"; then
PKG_CHECK_MODULES([TEST_SERVICE],[indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
dbustest-1 >= $DBUSTEST_REQUIRED_VERSION
- dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION])
+ dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION],
+ [enable_tests="yes"],
+ [enable_tests="no"])
fi
fi
AM_CONDITIONAL([BUILD_TESTS],[test "x$enable_tests" = "xyes"])