aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-04-26 14:34:38 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-04-26 14:34:38 -0500
commit705eb1b42bd83149592a284a035b54c3346936da (patch)
treef678edaeb08050f4edbfbeba4b798b4a4953bab3 /configure.ac
parent1ddba0eb336a87dafc522f15be584ba4cbdc97d5 (diff)
downloadayatana-indicator-session-705eb1b42bd83149592a284a035b54c3346936da.tar.gz
ayatana-indicator-session-705eb1b42bd83149592a284a035b54c3346936da.tar.bz2
ayatana-indicator-session-705eb1b42bd83149592a284a035b54c3346936da.zip
add scaffolding for indicator-session-service Google Testing with libdbustest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1ef7d50..4a1317e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,7 @@ IT_PROG_INTLTOOL([0.35.0])
AC_ISC_POSIX
AC_PROG_CC
+AC_PROG_CXX
AM_PROG_CC_C_O
AC_STDC_HEADERS
AC_PROG_LIBTOOL
@@ -32,6 +33,7 @@ GTK3_REQUIRED_VERSION=3.0
INDICATOR_REQUIRED_VERSION=0.3.19
DBUSMENUGTK_REQUIRED_VERSION=0.5.90
POLKIT_REQUIRED_VERSION=0.92
+DBUSTEST_REQUIRED_VERSION=0.0.5
AC_ARG_WITH([gtk],
[AS_HELP_STRING([--with-gtk],
@@ -87,6 +89,8 @@ AS_IF([test "x$with_gtk" = x3], [
AC_DEFINE(HAVE_GTK3, 1, [whether gtk3 is available])
])
+PKG_CHECK_MODULES(LIBDBUSTEST, dbustest-1 >= DBUSTEST_REQUIRED_VERSION)
+
###########################
# GTK Logout Helper
###########################
@@ -170,6 +174,13 @@ else
fi
AC_SUBST(DBUSSERVICEDIR)
+###########################
+# Google Test framework
+###########################
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+
##############################
# Custom Junk
##############################
@@ -236,6 +247,7 @@ data/icons/scalable/Makefile
data/icons/scalable/actions/Makefile
data/icons/scalable/status/Makefile
data/extra-sessions/Makefile
+tests/Makefile
po/Makefile.in
])